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Copyrights and Disclaimers 
 

Copyright©2017 Berger Engineering. All Rights Reserved.  

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and 

associated documentation files (the "Software"), to deal in the Software without restriction, including 

without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies 

of the Software, and to permit persons to whom the Software is furnished to do so, subject to the 

following conditions: 

The above copyright notice and this permission notice shall be included in all copies or substantial portions 

of the Software. 

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, 

INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 

PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE 

LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT 

OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR 

OTHER DEALINGS IN THE SOFTWARE. 

Contact Berger Engineering, 5667 Stone Road, Suite 465, Centreville, VA 20120, sales@w4krl.com for 

commercial licensing opportunities. 

 

Third Party Software Disclaimer 
Any links to third-party software available in this document are provided "as is" without warranty of any 

kind, either expressed or implied and such software is to be used at your own risk. 

The use of the third-party software links on this website is done at your own discretion and risk and with 

agreement that you will be solely responsible for any damage to your computer system or loss of data 

that results from such activities. You are solely responsible for adequate protection and backup of the 

data and equipment used in connection with any of the software linked to this website, and we will not 

be liable for any damages that you may suffer in connection with downloading, installing, using, modifying 

or distributing such software. No advice or information, whether oral or written, obtained by you from us 

or from this website shall create any warranty for the software. 

 

APRS® is a registered trademark of Bob Bruninga, WB4APR  

ARDUINO® and other Arduino brands and logos are trademarks of Arduino AG. 
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ESD Warning 
This product, like all microcontroller products, uses semiconductors that can be damaged by electrostatic 

discharge (ESD). When handling, care must be taken so that the devices are not damaged. Damage due 

to inappropriate handling is not covered by the warranty. 

The following precautions must be taken: 

❖ Do not open the protective conductive packaging until you have read the following, and are at an 

anti-static work station. 

❖ Use a conductive wrist strap attached to a good earth ground. 

❖ Use a soldering iron or station that is marked as ESD-safe.  

❖ Always discharge yourself by touching a grounded bare metal surface or anti-static mat before 

picking up an ESD-sensitive electronic component.  

❖ Use an anti-static mat to cover your work surface. 
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Illustrated Parts List 
 

 

 
 

Printed Circuit Board (PCB) Enclosure Solar Panel 

 

 

 

D1 Mini & Headers BME280 Breakout & Header BH1750 Breakout & Header 

 

 

 

Micro USB Cable Lithium Ion Cell TP4056 Breakout 

 

 

 

Slide Switches (2) Header Stick Shunt Jumper 

 

 

 

Resistor (180 KΩ) Screw Terminal 2-Conductor Wire 

 

 

 

Screws & Spacers (4 sets) Tie-Wrap Mount Hinge Pins (2) 

 

NOTE: Parts may vary from photographs. 
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Description of Operation 

The D1M-WX1 IoT Weather Station uses an ESP8266 System on Chip microcontroller to read and interpret 

weather data from sensors, format the data so that it is understandable by on-line services, and transmit 

the data to the Internet over Wi-Fi. The unit is completely solar powered with a Lithium Ion cell to maintain 

operation in darkness. 

Power Supply 
Solar energy derived from sunlight is converted into electrical energy by a solar panel. The panel is 

composed of a series string of silicon photovoltaic cells. In bright sunlight, the panel produces 6 volts at 

up to 100 mA. 

To continue operation at night and on dark days, a lithium-ion cell stores excess electrical energy when 

available. A TP-4056 charger regulates the solar-generated electrical power to maintain the charge 

without overcharging the cell.  

The ESP8266 microcontroller operates when supplied with voltage between 3.0 and 3.5 V DC. A fully 

charged cell has a terminal voltage of about 4.2 V DC that gradually drops to 3.0 V DC as energy is 

consumed. The D1 Mini breakout board includes a voltage regulator that supplies the microcontroller with 

3.0 to 3.3 V DC from an input voltage in the range of 3.1 to 10 V DC connected to the pin labelled VIN on 

the D1 Mini. When the lithium ion cell in connected to this terminal, the cell will safely supply the D1 Mini. 

The 3.3 V DC output of the D1 Mini regulator is connected to the 3V3 pin. A limited amount of current 

may be drawn from the 3V3 pin to supply the sensors with electrical power. 

Switch SW1 is the power switch for the station. When in the ON position, the cell is connected to the D1 

Mini. In the OFF position, the cell can be charged with solar power or with power drawn from a USB supply 

connected to the micro USB jack on the TP4056 breakout board. 

The D1 Mini can also be powered through its micro USB jack, however, a diode on the D1 Mini breakout 

board prevents power from flowing to the cell. The cell will not charge when power is supplied only to the 

D1 Mini board from a USB connection. 

ESP8266 System on Chip 
The ESP8266 is a powerful microcontroller that incorporates a Wi-Fi transceiver and flash memory. It is a 

surface mount device (SMD) that requires a few additional components to function in the weather station. 

Two important supporting components are the voltage regulator previously described and a USB adapter. 

These and other components are mounted to the back side of the breakout board. 

The main function of the USB adapter is to convert signals to and from a PC to RS-232 (EIA-232) serial 

signals used by the ESP8266 for programming and communication. Additional components enable the 

USB chip to control the programming and operating state of the ESP8266. 

The ESP8266 is supplied with a firmware LUA interpreter. LUA is an interesting computer language that 

does not yet have the wide support enjoyed by the Arduino flavor of C++. Fortunately, a dedicated band 

of programmers has developed an ESP8266 core. When the core is loaded into the Arduino Integrated 

Development Environment (IDE) it enables programming the ESP8266 exactly like it was an Arduino. This 

makes the huge Arduino ecosystem available to users of the ESP8266. 
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Deep Sleep 
One of the many interesting features of the ESP8266 is its ability to go into a very low power mode called 

deep sleep. This is an important feature for the weather station since it relies upon the limited energy 

available from the lithium ion cell during periods of darkness. 

Measurements show that the D1 Mini and the weather sensors draw around 80 µA when in deep sleep; 

a very small amount of current. However, in the six to ten seconds the station is transmitting data to the 

Internet, it may draw up to 300 mA with an average of about 80 mA. If the sleep mode was not available, 

the station would require a much larger solar panel and storage cell. 

When in deep sleep, the only active part of the ESP8266 is an internal real time clock (RTC). The weather 

station firmware sets the RTC to wake up the ESP8266 after ten minutes of deep sleep. When the sleep 

interval has expired, the RTC pulls pin D0 to ground. To wake up the processor, the reset pin RST must be 

pulled to ground. When the RUN/PROG switch is in the RUN position, the reset signal from D0 is connected 

to the RST pin and the chip will wake itself up every ten minutes. Unfortunately, pin D0 is also used by the 

USB adapter to control the programming of the ESP8266 and would be affected by the RTC reset function. 

When the switch is in the PROG position, the connection between D0 and RST is opened allowing normal 

programming of the chip. It is important to return the RUN/PROG switch to the RUN position after 

programming. 

I2C Interface Bus 
Data and control information is exchanged between the sensors and the microprocessor over an I2C serial 

bus. The I2C bus is ideally suited for the relatively low data rates needed for weather measurements and 

needs only two data pins on the D1 Mini. The software drivers for the I2C bus are built in to the Arduino 

software making it very easy to connect compatible I2C sensors to the microcontroller. Each I2C device 

must have a unique address. Some devices allow selection of the address and some do not. Often, in the 

case where the address is fixed, the driver library software has the address hard coded. This is the case 

with both sensors used in the weather station. 

Additional I2C devices may be connected to the controller through a 4-pin header on the PCB. In the case 

where external sensors may use the same I2C address, the local sensors may be disabled by removing the 

jumper on the LOCAL header pins. 

BME280 Environmental Sensor 
The BME280 Environmental Sensor by Bosch Sensortech is a high accuracy sensor for pressure, 

temperature, and humidity. These are the primary weather parameters measured by the station.  

The actual device is in a package 2.5 mm square and less than 1 mm thick. The breakout board requires 

just four wires: VIN and GND for power, and SCL and SDA for the I2C serial bus. 

The measurements made by the BME280 are linear, floating point values. As with most sensors, the 

measurement units are metric and may be converted to US units by simple mathematic routines. 

Generally, the placement of the weather station will not affect pressure and humidity measurements. 

Temperature measurements may be affected by solar heating of the weather station enclosure. If you 

notice unrealistically high temperatures during the day, you may wish to relocate your station so that 

direct sunlight does not fall on it. Good ventilation above and below the station is also important. 
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BH1750 Light Intensity Sensor 
The BH1750FVI Ambient Light Sensor by ROHM Semiconductor is an I2C device with a spectral response 

very similar to the human eye. Unlike the eye, however, its amplitude response is linear rather than 

logarithmic. Its range of 1 to 65,535 lux responds to intensities from cloudy moonlight to medium bright 

sunlight. This is adequate to provide a relative measure of the brightness of cloudy and sunny days. 

The light intensity measurement is strongly affected by the location of the weather station. Useful 

measurements can be obtained by a station not in direct sunlight. As with most light sensitive devices, the 

angle of incidence of the light strongly affects the measurement. This means that light from directly over 

the sensor will register a higher intensity than light coming from an angle. This is similar to the heating 

effect of sunlight on the earth and accounts for winter being colder than summer. 

Charge Monitor 
In addition to weather data, the station reports the lithium ion cell voltage to provide an indication of the 

state of the charge. The voltage is measured using the analog to digital converter (ADC) built into the 

ESP8266. The ADC has a range of 0 to 1 Volts that is reported as a 10-bit digital value from 0 to 1023. Since 

the cell voltage may exceed 4.2 V DC at full charge, it is necessary to use a voltage divider to reduce the 

voltage applied to the ESP8266. The D1 Mini has a voltage divider composed of a 220 kilohm resistor and 

100 kilohm resistor that increases the range to 0 to 3.2V DC. The station adds an external resistor of 

180 kilohm to further increase the range to 5 Vdc. 

While all three voltage divider resistors are precision devices, an optional calibration step is provided to 

ensure good accuracy. 

Received Signal Strength Indicator 
The Received Signal Strength Indicator (RSSI) is a function built into the Wi-Fi receiver of the ESP8266. 

RSSI is a measure of the power level of the Wi-Fi signal from your access point. There is no standard for 

the accuracy of the RSSI value, however it is common (whether accurate or not) to show the value as 

decibels referenced to a milliwatt written as dBm. Since the received power is very small the RSSI is a 

negative value when given in dBm. The closer the figure is to zero, the better. As a general example, a 

good signal would be -50dBm, a reasonable strength would be -75 dBm, a bad one would be -90 dBm, 

and -100 dBm would provide no service at all. 

The weather station reports the RSSI to help you judge how reliable the Wi-Fi signal is at the station 

location. It may also be an interesting experiment to see if there is a relationship between signal strength 

and weather conditions. For example, higher humidity may reduce signal strength. 
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Assembly Instructions 

Outline of Assembly Steps 
1. Identify the parts, collect your tools, find a good work location. 

2. Read this Assembly Manual and view the YouTube videos. 

3. Assemble the PCB and install the breakout boards and other electronic parts. 

4. Install the ESP8266 core and Arduino IDE software. Test with the calibration software. 

5. Create a ThingSpeak account and program the D1 Mini with the weather station software. 

6. Prepare the enclosure. 

7. Install the lithium ion cell, PCB, and solar cell in the enclosure. 

8. Mount the station outdoors and monitor your data on ThingSpeak. 

YouTube Videos 
Links to YouTube videos are on the D1M-WX1 Weather Station project web page. 

• PCB Assembly 

• Install the ESP8266 Core in the Arduino IDE 

• Box Assembly 

Tools Needed: 
If you’ve built kits before you probably have all these tools. These are some suggested tools for new kit 

builders. Most are inexpensive tools that you will use again if you build other kits. 

1. Soldering iron or station with good quality rosin-core solder. A 30-watt iron is satisfactory. It 

should have a conical tip. The tip should be grounded so the iron should have a three-prong plug. 

The X-Tronic Model #3020 is an excellent choice for a temperature controlled iron. Marlin P. Jones 

& Assoc., www.mpja.com, has a wide selection of irons in all prices. 

2. Small diagonal cutters such as Harbor Freight #40695. 

3. Phillips screwdriver. 

4. Hot melt glue gun such as the Walmart Low-Temp Mini Glue Gun #557243715. 

5. 1/8-in and 1/4-in (3mm & 6mm) drill bits. Harbor Freight #69470 handle & #61621 drill bits. 

6. Optional flush cutter to trim excess leads. A good choice is the Hakko CHP-170. Harbor Freight 

#90708 is also acceptable. 

7. Optional needle-nose pliers. Useful for picking up parts and bending leads. Harbor Freight #40696. 

8. Optional digital multimeter for voltage calibration. Harbor Freight #90899. 

9. Optional magnifying lens to inspect the soldering. 

Assemble the Printed Circuit Board 
Find a good location to build the kit, assemble your tools, and identify the parts. 

1. Mount spacers to the PCB. Apply the nylon spacers and screws finger tight in four places. This 

permits using the PCB as a stable fixture for installing the breakout boards and other parts. 

2. TP-4056 Charger Assembly and Installation 

1. Cut four individual pins from the male header stock using diagonal or end cutters. Be neat! 

2. Place the four pins on the PCB with the long tails through the PCB. 

3. Carefully place the TP-4056 breakout board on the pins. Observe proper orientation of 

the pins, that is, BAT+ to BAT+, etc. 

http://w4krl.com/d1m-wx1-solar-powered-weather-station/
https://www.youtube.com/watch?v=jDRei0EBPoo
https://youtu.be/7St5Ra21Cpw
https://www.youtube.com/watch?v=AdvJXJEiF54
https://www.amazon.com/X-Tronic-3020-XTS-Digital-Display-Soldering/dp/B01DGZFSNE
http://www.mpja.com/
http://www.harborfreight.com/4-1-2-half-inch-diagonal-cutters-40695.html
https://www.walmart.com/ip/Adtech-Low-Temp-Mini-Gun/105168885
http://www.harborfreight.com/4-in-1-screwdriver-with-tpr-handle-69470.html
http://www.harborfreight.com/titanium-nitride-coated-high-speed-steel-drill-bit-set-13-pc-61621.html
https://www.amazon.com/Hakko-CHP-170-Stand-off-Construction-21-Degree/dp/B00FZPDG1K/ref=sr_1_1?s=hi&ie=UTF8&qid=1488917699&sr=1-1&keywords=chp-170
http://www.harborfreight.com/micro-flush-cutter-90708.html
http://www.harborfreight.com/5-3-4-quarter-inch-needle-nose-pliers-40696.html
http://www.harborfreight.com/7-function-digital-multimeter-90899.html
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4. Solder the pins to the TP4056 (4 places). 

5. Turn over the PCB. Keep the TP4056 flush on the PCB and solder the four TP4056 pins to 

the PCB. 

6. Trim the pins with the diagonal or flush cutters. 

7. Return the board to the face up position. 

3. D1 Mini Assembly and Installation 

1. Place two 8-pin male headers on the PCB at the D1 Mini outline with the long tails of the 

pins through the board. 

2. Place the D1 Mini on the header pins with the ESP8266 side up. 

3. Solder pins on the four corner off the D1 Mini being careful to keep the D1 Mini square 

with the PCB. The corner pins are RST, TX, 5V, and 3V3. 

4. Solder the remaining pins on the D1 Mini. 

5. Turn over the board, keeping the D1 Mini flush with the PCB, and solder all 16 D1 Mini 

pins to the PCB. 

6. Trim the pins. 

7. Return board to the face up position. 

4. BME280 Assembly and Installation 

1. Place the 4-pin header on the PCB with the LONG tails through the PCB. 

2. Carefully place the BME280 breakout board on the pins. 

3. Solder the VIN pin to the BME280. Place the tip of your iron on the short side of the board 

to raise the board away from the PCB. Try to keep the board parallel to the PCB. 

4. Solder the remaining pins (3 places) to the BME280.   

5. Turn over the PCB and solder the four BME280 pins to the PCB. 

6. Trim the pins. 

7. Return the board to the face up position. 

5. BH1750 Assembly and Installation 

1. Place the 5-pin header on the PCB with the LONG tails through the PCB. 

2. Carefully place the BH1750 on the pins. 

3. Solder the VCC pin to the BH1750. Place the tip of your iron on the short side of the board 

to raise the board away from the PCB. Try to keep the board parallel to the PCB. 

4. Solder the remaining pins (4 places) to the BH1750.  

5. Turn over the PCB and solder the five BH1750 pins to the PCB. 

6. Trim the pins. 

7. Return the board to the face up position. 

6. I2C Header Assembly and Installation 

1. Cut a stick of four (4) pins from the male header stock. 

2. Place the SHORT tails of the pins through the PCB at the I2C location. 

3. Turn over the PCB and solder the four pins to the PCB. 

4. Return the PCB to the face up position. 

7. LOCAL Header Assembly and Installation 

1. Cut a stick of two (2) pins from the male header stock. 

2. Place the SHORT tails of the pins through the PCB at the LOCAL location. 

3. Turn over the PCB and solder the two pins to the PCB. 

4. Return the PCB to the face up position. 
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5. Place a shunt jumper on the LOCAL header pins. 

8. Resistor Installation 

1. Place the 180 kilohm resistor in the resistor location. 

2. Turn over the PCB and solder the two (2) resistor leads to the PCB. 

3. Trim the resistor leads. 

4. Return the PCB to the face up position. 

9. Slide Switch Installation 

1. Place one Slide Switch in the PROG-RUN location. 

2. Turn over the PCB and solder the three (3) Slide Switch Pins to the PCB. 

3. Trim the pins. 

4. Return the PCB to the face up position. 

5. Repeat the installation steps for the ON Slide Switch. 

10. Screw terminal installation 

1. Carefully insert the 2-point screw terminal into the PCB at the CELL location. Make sure 

the wire openings point to the outside of the PCB. 

2. Solder the terminals (2) on the underside of the board. 

11. Connect the solar panel lead 

1. There are two options for connecting the solar panel: 1) solder the leads directly to the 

PCB, or 2) use a 2-pin connector and fly lead. Option 1 makes a neat arrangement but the 

lid and solar panel are permanently connected to the PCB. Option 2 requires making a 

joint between the connector fly lead and the wire connected to the solar panel. If you are 

new to kit building you may wish to use Option 1. 

i. Option 1 

1. Prepare the two-conductor wire. This wire will connect the solar panel to 

the PCB in a later step. 

2. Separately twist the strands in each lead and tin the leads by applying a 

minimum amount of solder. 

3. Insert the RED (positive) lead of the cell through the positive (+) terminal 

on the top of the PCB. 

4. Solder on the bottom side of the board. 

5. Repeat for BLACK (negative) wire. 

6. Trim any excess length of the wire on the bottom side of the board. 

ii. Option 2 

1. Unplug the female fly lead connector from the PCB-mounted make 

connector. 

2. Place the 2-pin male connector on the top side of the PCB and solder it 

on the underside of the board. 

3. Solder the Fly leads to the 2-conductor wire. Red to red and black to 

black. 

4. Insulate the two wires from each other with a wrap of electrical tape on 

each joint. Place a tape wrap around the joint. 

5. Remount the connectors. The wire will be connected to the solar panel 

in a later step. 

12. Inspect the PCB 
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1. Check that all parts are in the correct orientation. 

2. Check that all solder joints are good. 

3. Check that there are no bent pins or shorts between PCB solder pads. 

Install Arduino IDE and ESP8266 Software 
This is a convenient point to install and test the software. It is easier to work with the PCB when not 

connected to the lithium-ion cell and solar panel. Those components will be connected in the final 

assembly. 

The Arduino software is an Integrated Development Environment (IDE) that makes it easy to create, edit, 

compile, and upload firmware to Arduino compatible microcontrollers. A dedicated group of volunteers 

have written an add-in for the IDE that extends its capabilities to the ESP8266 System on a Chip as used 

on the D1 Mini in this kit. Almost all of the extensive Arduino library files can be used with the ESP8266. 

These steps install the Arduino IDE and the ESP8266 core onto your personal computer. 

1. Download the Arduino IDE from https://www.arduino.cc/en/Main/Software. Be sure to select the 

version appropriate to your PC. Detailed instructions for Windows are provided at 

https://www.arduino.cc/en/Guide/Windows. 

2. The installation adds a desktop icon for Arduino. Click on it to run the IDE. 

 

The following steps 3 to 6 are illustrated in a YouTube video. 

3. Open menu item File > Preferences. 

4. Enter http://arduino.esp8266.com/stable/package_esp8266com_index.json into the Additional 

Board Manager URLs field. You may copy from this document and paste it in the text box to avoid 

making a typing error. 

5. Check the box for Display line numbers. Click OK to close the Preferences dialog. 

6. Open Boards Manager from Tools > Board menu and enter esp8266 in the search box. Click on 

“online help”. Click on the Install button to install. Close the Boards Manager dialog when finished. 

7. Use File > Open for D1M-WX1_Calibration.  

8. Use meu Tools > Board and select WeMos D1 R2 & mini In the section labelled ESP8266 Modules. 

9. Plug in the Micro USB cable to your computer and the D1 Mini. Make certain you are plugging in 

to the D1 Mini, not the TP4056. Your computer should install a COM port. Select the new COM 

port from menu item Tools > Port: You can use Windows Device Manager to find the port number. 

10. If you have any difficulty with the above steps, the latest version of these instructions is located 

at https://github.com/esp8266/Arduino. Use the instructions for “Installing with Boards 

Manager.”  There are nicely illustrated instructions at http://randomnerdtutorials.com/how-to-

install-esp8266-board-arduino-ide/ 

Download the D1M-WX1 Weather Station Firmware 
These steps will download the weather station firmware to your PC. You will compile and upload the 

Arduino software in later steps. 

1. Download the weather station firmware: 

1. Navigate you PC web browser to http://w4krl.com/d1m-wx1-solar-powered-weather-

station/. Scroll to Weather Station Firmware. 

https://www.arduino.cc/en/Main/Software
https://www.arduino.cc/en/Guide/Windows
https://www.youtube.com/watch?v=7St5Ra21Cpw&feature=youtu.be
https://github.com/esp8266/Arduino
http://randomnerdtutorials.com/how-to-install-esp8266-board-arduino-ide/
http://randomnerdtutorials.com/how-to-install-esp8266-board-arduino-ide/
http://w4krl.com/d1m-wx1-solar-powered-weather-station/
http://w4krl.com/d1m-wx1-solar-powered-weather-station/
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2. Click on D1M-WX1_Weather_Station. This will download the D1M-

WX1_Weather_Station.zip file to your download folder. 

3. Double-click on the ZIP file and choose Extract all. Click Extract. The files will appear in a 

new folder called D1M-WX1_Weather_Station. 

4. Open the D1M-WX1_Weather_Station folder. Hold down your Control key and click on 

each of the three folders: D1M-WX1_Calibration, D1M-WX1_IoT, and D1M-WX1_IoT-

APRS. Right-click to copy these three folders. 

5. Locate your Arduino sketch folder. This is usually \Documents\Arduino. Left-click to Paste. 

6. In the IDE, click menu item File > Open… You should see the three folders you just copied 

to your Arduino directory. 

2. Additional library software provided by others is needed for the sensors.  

1. Install the library for the BME280 sensor: 

i. In the IDE, open menu item Sketch > Include Library > Manage Libraries… 

ii. Type BME280 in the Filter your search… box. 

iii. Install the library for BME280 by Tyler Glenn. 

2. Install the library for the BH1750 sensor: 

i. Open https://github.com/claws/BH1750 in your browser. 

ii. Click on the Clone or download button and choose Download ZIP. This will 

download BH1750-master.zip to your PC’s Downloads folder. 

iii. In the IDE, open menu item Sketch > Include Library > Add .ZIP Library… Navigate 

to your Downloads folder and select the BH1750 file. 

Verify IDE & Calibrate Voltage Sensor 
These steps verify proper installation of the Arduino IDE software and the ESP8266 core. Optional steps 

are included to calibrate the voltage sensor.  

While the voltage calibration procedure is optional, it is recommended. The kit is supplied with quality 

components; however, normal parts variations may account for as much as ±10% deviation from accurate 

voltage measurement. 

You will need a digital multimeter for the calibration steps. 

1. Connect the D1 Mini to your PC with the Micro USB cable. 

2. Verify that the PROG/RUN switch on the PCB is in the PROG position. 

3. Verify that the power switch on the PCB is in the ON position. 

4. Verify that menu Tools > Port: is showing the correct COM port. 

5. Verify that menu Tools > Board: is showing “WeMos D1 R2 and mini” 

6. Use menu File > Open to open D1M-WX1_Calibration.ino. 

7. Use menu Sketch > Upload or type Control+U. The IDE will compile the sketch and begin to upload 

it to the D1 Mini. A small LED next to the ESP8266 with rapidly flash during the upload. 

8. The D1 Mini will start running the firmware as soon as the upload is complete. The small LED 

should repeatedly blink one second on and one second off. This verifies that you have installed 

the IDE and core correctly and can upload to the D1 Mini. 

9. Voltage Calibration: Use menu Tools > Serial Monitor or type Control+Shift+M. The serial monitor 

window will open. Change the baud rate in the dropdown box in the lower right of the window to 

115200 baud. You will see voltage measurements appear every two seconds. This is the voltage 

http://w4krl.com/wp-content/uploads/D1M-WX1_Weather_Station.zip
https://github.com/claws/BH1750
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measured by the ESP8266 analog to digital converter. It is normal for the voltage to change slightly 

between measurements. Write down a voltage that appears to be an average of the measurements. 

10. Turn you DMM to the 20-Volt DC scale. Measure the voltage between the screws on the CELL terminal 

block. Write down the average voltage.  

11. The ADC and DMM voltages will be used to calibrate the weather station software in a later step. 

Compile & Upload the D1M-WX1_IoT.ino Firmware 
These instructions will install and configure the Internet of Things version. It will report weather data only 

to the free ThingSpeak IoT service. The IoT code is smaller and easier to use than the APRS-IS code. It is 

recommended to do this installation first.  

Find your station altitude in meters by entering its street address in veloroutes.org. Having the correct 

altitude is important for the accuracy of the barometric pressure sensor. 

1. Open a free account at ThingSpeak: 

1. Open www.thingspeak.com in your browser. 

2. Click “Sign Up”. 

3. Select and record your UserID. 

4. Change Time Zone to GMT-5:00 Eastern Time. 

5. Select and record your Password. 

6. Agree to Terms. 

7. Click Create Account. 

8. On next screen click “New Channel”. 

9. Choose and record the channel name. 

10. Enter field definitions and check the box beside each of the following. 

1 = Temperature 
2 = Humidity 
3 = Station Pressure 
4 = Sea Level Pressure 
5 = Light Intensity 
6 = Cell Voltage 
7 = RSSI 
8 is not used. Do not change the defaults. 

11. Make Public. 

12. Elevation = your elevation in meters. 

13. Check Show Location. 

14. Latitude = your latitude in decimal degrees. 

15. Longitude = your longitude in decimal degrees. Negative for west. 

16. Click on Save Channel. 

17. Record your API Keys. 

2. Set the PROG/RUN switch on the PCB to PROG. 

3. Using the Arduino IDE, open file D1M-WX1_IoT.ino. Note that the IDE window has a tab for D1M-

WX1_IoT and config.h. 

4. Select the cofig.h tab and enter the information indicated: 

1. dmmVoltage and adcVoltage determined in the calibration step or use the defaults. 

http://veloroutes.org/
http://www.thingspeak.com/
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2. STATION_ELEVATION in meters. 

3. SLEEP_INTERVAL = 600; 

4. ssid[] = your Wi-Fi SSID in quotes. Use only 2.4GHz networks, 5GHz networks will not 

work! 

5. password[] = your Wi-Fi password in quotes. 

6. ChannelID = your ThingSpeak channel ID in quotes. 

7. apiWriteKey = your ThingSpeak API Write Key in quotes. 

5. Use IDE menu File > Save or type Control+S to save your changes. 

6. Compile and upload the firmware with Sketch > Upload or Control+U. 

7. Turn the PROG/RUN switch to RUN. 

8. Log on to your ThingSpeak account to see your Internet of Things data. 

Prepare the enclosure: 
1. Drill 1/8-inch (3 mm) holes in the box sides as shown in Figure 1, twelve places. This will provide 

ventilation for the sensors. 

2. Place the PCB in the box as shown in Figure 1. Mark the location of the mounting spacers on the 

outside of the box with a permanent marker. 

3. Drill ¼-inch (6 mm) large ventilation holes in the bottom of the box as indicated in Figure 1. Make 

sure the holes do not interfere with the mounting locations. 

4. This step must be done quickly: Put a dab of hot melt glue in the bottom of the box at each location 

(4) marked. Insert the PCB with the spacers in the glue spots making sure the PCB box is square 

with the box. Hold until the glue is set. (about 30-seconds). 

5. Place some hot melt glue in lines on the box lid where as shown in Figure 1. Press a hinge pin in 

each line of glue with the hinge pressed against the box edge. Allow glue to set. 

6. Test fit the solar panel to the hinges. When you are satisfied with the fit, spread glue on the pins 

and press the solar panel against the pins. Hold until the glue is set. 

7. Make sure the box is clean and dry at the mounting location shown for the tie-wrap mount. 

Remove the paper backing from the tie-wrap mount and press against the box as shown. Hold for 

30 seconds. 
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Figure 1 – Box Locations 
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Final assembly 
1. Lithium Ion Cell Assembly and Installation 

1. Turn the slide switch to the OFF (not ON) position. 

2. If the cell leads are provided with protective tape, carefully remove the tape from the cell 

leads.  

WARNING: KEEP LEADS FROM TOUCHING EACH OTHER! 

3. If the cell is provided with a connector, carefully cut each lead from the connector as close 

to the connector as possible. Cut the leads ONE BY ONE.  

WARNING: DO NOT CUT ACROSS BOTH WIRES AT THE SAME TIME! 

4. Strip about ¼-inch (6mm) from each lead. 

5. Separately twist the strands in each lead and tin the leads by applying a minimum amount 

of solder. 

6. Insert the RED (positive) lead of the cell into the positive (+) screw terminal. Tighten the 

screw to hold the wire in place. DO NOT OVERTIGHTEN. 

7. Insert the BLACK (negative) wire in the other screw terminal. Tighten the screw to hold 

the wire in place. DO NOT OVERTIGHTEN. 

8. Loosely place the cell on the underside of the board. 

2. Charge the lithium cell by plugging your Micro USB connector into the socket on the TP4056 

board. The orange light indicates charge. The blue light indicates full charge. 

3. Solar Panel connection 

1. Locate the free end of the two-conductor wire.  

2. Separately twist the strands in each lead and tin the leads by applying a minimum amount 

of solder. 

3. Carefully solder the RED (positive) lead to the positive (+) solder pad on the rear of the 

solar panel near its middle. DO NOT OVERHEAT THE SOLAR PANEL. 

4. Carefully solder the BLACK (negative) lead to the negative (-) solder pad on the rear of the 

solar panel. This is the other pad near the center of the panel. 

5. Apply dabs of hot melt glue over the connections to protect the solder joints from 

weather. 

6. Apply a dab of hot melt glue to the wire to hold it in place against the solar panel. 

7. Put the lid on the box with the wire routed under the lid. There should be a drip loop in 

the wire to prevent rain from following the wire into the box. 

Congratulations! You have completed the assembly of your Internet of Things weather station. 

Mount the Weather Station 
The station should be mounted so that air can circulate around the box. It is best to mount the box from 

the side so that the vent holes in the bottom of the box are not blocked. 

It can be attached to a deck rail or tree branch by looping a tie wrap around the box. Do not rely on 

supporting the box from the tie wrap mount as the glue may loosen in weather. One or more tie-wraps 

connected in series will work on large objects. Duct tape can be useful. 
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The solar cell should face mostly south toward the daytime sun. 

Avoid a location exposed to direct sunlight. It will raise the temperature within the box affecting the 

accuracy of the temperature measurement. 

Using the APRS Station 
You must be a licensed amateur radio operator and have a valid callsign. Any license class may use the 

station as it does not require transmission on the amateur bands. 

The config.h file for D1M-WX1_IoT-APRS.ino must be filled in with the information for your station. You 

must also enter the same information you provided for the IoT-only version of the firmware. 

Obtain an APRS passcode at www.george-smart.co.uk/aprs/aprs_callpass/ or n5dux.com/ham/aprs-

passcode. 

You will need to know your station location in decimal degrees and altitude in meters. To find your 

position, go to mygeoposition.com, enter your address and write down your position in degrees, minutes, 

and seconds. Convert seconds to decimal degrees by dividing by 60 and adding it to your degrees. Rewrite 

your position in the APRS format of ddmm.hhN/ dddmm.hhW. For example, the location of the Udvar-

Hazy Center is 38⁰ 54’ 39.31’’ N, 77⁰ 26’ 39.15’’ W. The latitude is 38 degrees. The minutes are 54. Convert 

the seconds to decimal minutes by diving by 60, that is, 39.31/60 = 0.6551666. Add this number to the 

minutes and round to two decimal places: 54.66. The final location is 3854.66N/07726.65W. Read this as 

38 degrees 54.66 minutes north and 77 degrees 26.65 minutes west. 

A simpler approach is to use only the degrees and minutes and enter seconds as 00. In this case the 

location may be given as 3854.00N/07726.00W. This is accurate to about a mile. 

Set the PROG/RUN switch to PROG and upload the new firmware. Set the switch back to RUN. The unit 

will transmit weather and telemetry every 10 minutes. Go to aprs.fi and search for your callsign and SSID 

to see your data. 

http://www.george-smart.co.uk/aprs/aprs_callpass/
http://n5dux.com/ham/aprs-passcode/
http://n5dux.com/ham/aprs-passcode/
http://mygeoposition.com/
http://aprs.fi/
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I2C Expansion Header 
The 4-pin header marked I2C on the printed circuit board is provided for remote sensors or the addition 

of other I2C devices. 

Each I2C device must have a unique address. In some cases, the address is selectable by the user. This is 

not the case with the BME280 and BH1750 sensors. The onboard sensors must be disabled if remote 

BH1750 and BME280 sensors are added. Address conflict can be avoided by removing power to the 

onboard sensors. This is easily done by removing the shunt jumper from the 2-pin LOCAL header. 

NOTE: The I2C header pins are mislabeled on printed circuit boards marked Rev A. The labels for SDA 

and SCL are reversed. The proper labeling from left to right should be: VCC, GND, SDA, SCL 
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Troubleshooting 
PROBLEM CHECK 

Unit transmits data only once. The PROG/RUN switch may be in wrong position. 
Set PROG/RUN switch to RUN. 
 
Cell may not be charged. Connect a 5V USB source 
to the Micro USB socket on the TP4056 board until 
the blue LED lights. 
 
The unit may be out of Wi-Fi range. Move it closer 
to the Wi-Fi access point. 

Unit does not transmit data. Power switch may be in wrong position. Set switch 
to ON. 
 
Cell may not be charged. Connect a 5V USB source 
to the Micro USB socket on the TP4056 board until 
the blue LED lights. 
 
Cell wires may not be properly engaged in screw 
terminals. Verify wires are stripped and in contact 
with terminals. 
 
The unit may be out of Wi-Fi range. Move it closer 
to the Wi-Fi access point. 

IDE returns espcomm error Check that the unit is connected to your PC. 
 
Check that proper COM port is selected. 
 
Check that PROG/RUN switch is in the PROG 
position. 

IDE returns error compiling for board Verify that menu Tools > Board is set for WeMos 
D1 R1 & mini. 
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APPENDIX A - Schematic 
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Appendix B – APRS Tier 2 Servers in the US & Canada 
Complete global list at http://www.aprs2.net/serverstats.php 

Abilene texas.aprs2.net 
Acton ontario.aprs2.net 
Augusta maine.aprs2.net 
Baltimore bwi.aprs2.net 
Chilliwack ycw.aprs2.net 
Columbia missouri.aprs2.net 
Columbus cmh.aprs2.net 
Corvallis oregon.aprs2.net 
Dulles iad.aprs2.net 
Dulles iad2.aprs2.net 
Edmonton edmonton.aprs2.net 
Greenwood arkansas.aprs2.net 
Kansas City central.aprs2.net 
Los Angeles socal.aprs2.net 
Mishawaka indiana.aprs2.net 
Montreal raqi.aprs2.net 
New York lga.aprs2.net 
Providence newengland.aprs2.net 
San Jose sjc.aprs2.net 
San Juan puertorico.aprs2.net 
Seattle northwest.aprs2.net 
Toronto yyz.aprs2.net 
Tucson tus.aprs2.net 
Vancouver bc.aprs2.net 
Vancouver vancouver.aprs2.net 
  

http://www.aprs2.net/serverstats.php
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APPENDIX C – Useful Links 
 

APRS by Bob Bruninga, WB4APR http://aprs.org 

APRS general article http://www.arrl.org/automatic-packet-reporting-system-aprs  

APRS Google Maps http://aprs.fi  

APRS Passcode 
(licensed amateurs only) 

http://www.george-smart.co.uk/aprs/aprs_callpass/  
http://n5dux.com/ham/aprs-passcode  

APRS Protocol http://www.aprs.net/vm/DOS/PROTOCOL.HTM  

APRS Protocol Reference http://www.aprs.org/doc/APRS101.PDF  

APRS SSID Recommendations http://www.aprs.org/aprs11/SSIDs.txt  

APRS-IS connection http://www.aprs-is.net/Connecting.aspx  

Arduino C++ Reference https://www.arduino.cc/en/Reference/HomePage  

Arduino IDE https://www.arduino.cc/en/Main/Software  

Arduino Library Instructions https://www.arduino.cc/en/guide/libraries  

BH1750 Data Sheet http://image.dfrobot.com/image/data/SEN0097/BH1750FVI.pdf  

BME280 Data Sheet https://www.bosch-
sensortec.com/bst/products/all_products/bme280  

Civilian Weather Observer Program http://wxqa.com/  

D1M-WX1 Firmware http://w4krl.com/wp-content/uploads/D1M-
WX1_Weather_Station.zip 

D1 Mini Information https://www.wemos.cc/product/d1-mini.html  

ESP8266 Arduino core https://github.com/esp8266/Arduino  

ESP8266 Resources http://www.esp8266.com/  

Geographic Location & Altitude http://mygeoposition.com/ 
https://www.freemaptools.com/elevation-finder.htm 
http://veloroutes.org/elevation/  

APRS Location Converter (Excel) APRS-Location-Converter.xls 

IoT Kits at W4KRL http://w4krl.com/iot-kits 

IoT Kits firmware https://github.com/W4KRL  

ThingSpeak http://www.thingspeak.com  

ThingSpeak tutorials http://community.thingspeak.com/tutorials/  

 
  

http://aprs.org/
http://www.arrl.org/automatic-packet-reporting-system-aprs
http://aprs.fi/
http://www.george-smart.co.uk/aprs/aprs_callpass/
http://n5dux.com/ham/aprs-passcode
http://www.aprs.net/vm/DOS/PROTOCOL.HTM
http://www.aprs.org/doc/APRS101.PDF
http://www.aprs.org/aprs11/SSIDs.txt
http://www.aprs-is.net/Connecting.aspx
https://www.arduino.cc/en/Reference/HomePage
https://www.arduino.cc/en/Main/Software
https://www.arduino.cc/en/guide/libraries
http://image.dfrobot.com/image/data/SEN0097/BH1750FVI.pdf
https://www.bosch-sensortec.com/bst/products/all_products/bme280
https://www.bosch-sensortec.com/bst/products/all_products/bme280
http://wxqa.com/
http://w4krl.com/wp-content/uploads/D1M-WX1_Weather_Station.zip
http://w4krl.com/wp-content/uploads/D1M-WX1_Weather_Station.zip
https://www.wemos.cc/product/d1-mini.html
https://github.com/esp8266/Arduino
http://www.esp8266.com/
http://mygeoposition.com/
https://www.freemaptools.com/elevation-finder.htm
http://veloroutes.org/elevation/
http://w4krl.com/wp-content/uploads/APRS-Location-Converter.xls
http://w4krl.com/iot-kits
https://github.com/W4KRL
http://www.thingspeak.com/
http://community.thingspeak.com/tutorials/
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APPENDIX D – CONFIG.H 
 

// config.h 

 

// This configuration file should reside in the same Arduino 

// directory as the weather station file D1M-WX1_IoT-APRS.ino. 

 

// ******************************************************* 

// **************** STATION FACTORS ********************** 

// ******************************************************* 

 

// If you have performed the voltage calibration steps, enter 

// the voltage you measured on your digital multimeter and 

// the voltage reported by the ADC on the serial monitor. 

// If you have not performed the calibration, do not change  

// the default values. They should be equal. 

 

const float dmmVoltage = 4.45; 

const float adcVoltage = 4.45; 

 

// station altitude in meters 

// https://www.freemaptools.com/elevation-finder.htm 

const float STATION_ELEV = 90.0; 

 

// update interval in seconds 

// must be longer than 15 seconds 

// suggest 300 seconds for testing, 600 or 900 for use 

const long SLEEP_INTERVAL = 600; 

 

// ******************************************************* 

// ********************* WIFI LOGON ********************** 

// ******************************************************* 

 

// ENTER YOUR SSID 

// 2.4GHz Wi-Fi only 

const char ssid[] = "yourWiFi_SSID"; 

 

// ENTER YOUR PASSWORD 

const char password[] = "yourWiFi_PW"; 

 

// ******************************************************* 

// ******************** THINGSPEAK *********************** 

// ******************************************************* 
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// ThingSpeak Channel ID 

String ChannelID = "yourChannelID"; 

 

// API write key for your ThingSpeak channel 

String apiWriteKey = "yourAPI_write_Key"; 

 

// ThingSpeak Server - do not change 

const char IOT_SERVER[] = "api.thingspeak.com"; 

 

// ******************************************************* 

// ******************** APRS-IS ************************** 

// ******************************************************* 

 

// station location in APRS format 

// NOTE: latitude must have 4 digits left of the decimal. Pad with 0s. 

//       longitude must have 5 digits left of the decimal. Pad with 0s. 

// Find your location at aprs.fi using "Address, city or locator" box 

const char APRSlocation[] = "ddmm.hhN/dddmm.hhWW"; 

 

// select an APRS-IS Tier 2 server close to your station 

// or use the default 

// for list of servers: http://www.aprs2.net/serverstats.php 

const char APRS_SERVER[] = "iad.aprs2.net"; 

const int APRS_PORT = 14580;   // do not change 

 

// define your callsign and passcode 

// use SSID -13 for weather stations 

// see http://www.aprs.org/aprs11/SSIDs.txt 

const String APRScallsign = "callsign-ssid"; 

 

// for passcode www.george-smart.co.uk/aprs/aprs_callpass/ 

// or http://n5dux.com/ham/aprs-passcode/ 

const char APRSpasscode[] = "nnnn"; 

 

 


